Need help? See our Help Page

Other Platforms
 Windows Logo  Apple Logo  Android Logo  iOS Logo(iPad only)

DriveThruRPG Library App

This app allows you to easily sync your Library to your compatible device.

Mac Client Version 2.0.3.2
Requires macOS version 10.11 (El Capitan) or higher.
Apple LogoDownload Client

Library Application Screenshot

Installation Instructions

  1. Download then double click the installation file
  2. Drag the DriveThruRPG icon to the Application Folder icon
  3. Once the copying progress bar is done the app is installed.
  4. You may have a disk drive icon labelled DriveThruRPG on your desktop even after installation is complete.
    You do not need to keep it to run the app, right click and select eject to remove it.
  5. To begin using the app go to your applications folder and click the DriveThruRPG icon
  6. On your first launch of the app you may get a pop up like this since this is downloaded from a website. Just click on open to continue.
  • The client can sync your entire Library to your computer with all files organized in folders by publisher.
  • Automatically keep you up to date. When you run a Library sync in the client it downloads new files for any titles that publishers have updated since your last download.
  • Sort your Library by rule system in the client. Click to Open any file in your favorite viewer.
  • The client gets files you've purchased at any OneBookShelf site including DriveThruRPG, RPGNow, WargameVault, DMsGuild, DriveThru Comics, DriveThruFiction, and more.

More Information and FAQ

If you encounter any trouble during installation, some information is available in our Client Help page.
If you have any feedback about our Library Client please use the contact us button or suggestion box below.

Changelog

Version 2.0.3.2

March 19, 2018
Initial macOS Release

Coming Soon for More Operating Systems

  • Linux Logo

We'd Love Your Feedback

Have a suggestion for improving the client? Spot a bug we need to fix? Please tell us about it here:

 Suggestions?


Legal Stuff

This application uses the LGPL-licensed version of the Qt.io framework (source code available here). This application itself is not LGPL-licensed, but because we use this library, you are free to link to a modified version of it if you please. This also requires us to provide the text of the LGPL 3.0 license, shown below (or click here).